mirror of
https://github.com/NotAShelf/systemyml.git
synced 2024-11-01 11:01:18 +00:00
19 lines
309 B
Nix
19 lines
309 B
Nix
{
|
|
callPackage,
|
|
rust-analyzer,
|
|
rustfmt,
|
|
clippy,
|
|
}: let
|
|
mainPkg = callPackage ./default.nix {};
|
|
in
|
|
mainPkg.overrideAttrs (oa: {
|
|
nativeBuildInputs =
|
|
[
|
|
# Additional rust tooling
|
|
rust-analyzer
|
|
rustfmt
|
|
clippy
|
|
]
|
|
++ (oa.nativeBuildInputs or []);
|
|
})
|