projectile-simulation/flake.nix
2023-10-10 10:04:52 +03:00

26 lines
670 B
Nix

{
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
outputs = {
self,
nixpkgs,
}: let
systems = ["x86_64-linux" "aarch64-linux"];
forEachSystem = nixpkgs.lib.genAttrs systems;
pkgsForEach = nixpkgs.legacyPackages;
in {
packages = forEachSystem (system: {
default = self.packages.${system}.projectile-simulation;
projectile-simulation = pkgsForEach.${system}.callPackage ./default.nix {};
});
devShells = forEachSystem (system: {
devShells = {
default = self.devShells.${system}.python-shell;
python-shell = pkgsForEach.${system}.callPackage ./shell.nix {};
};
});
};
}