mirror of
https://github.com/NotAShelf/nyxexprs.git
synced 2024-11-01 11:01:16 +00:00
NotAShelf
68bdc4f3f0
Patched version of ZSH that provides remote file completion and special handling for special chars such as # or ^
35 lines
784 B
Nix
35 lines
784 B
Nix
{
|
|
lib,
|
|
zsh,
|
|
...
|
|
}:
|
|
zsh.overrideAttrs (old: {
|
|
patches =
|
|
(old.patches or [])
|
|
++ [
|
|
./0001-globquote.patch
|
|
|
|
# From:
|
|
# <https://github.com/fugidev/nix-config>
|
|
./0001-remote-complete-files.patch
|
|
];
|
|
|
|
postConfigure =
|
|
(old.postConfigure or "")
|
|
+ ''
|
|
# Find all instances of name=zsh/newuser in config.modules
|
|
# remove them.
|
|
sed -i -e '/^name=zsh\/newuser/d' config.modules
|
|
|
|
# Also remove the newuser script to try and save some space
|
|
# it doesn't amount to much, but every little bit counts.
|
|
rm Scripts/newuser
|
|
'';
|
|
|
|
meta = {
|
|
description = "Patched version of zsh with globquote and remote file completion";
|
|
mainProgram = "zsh";
|
|
maintainers = with lib.maintainers; [NotAShelf];
|
|
};
|
|
})
|