mirror of
https://github.com/NotAShelf/nvf.git
synced 2024-11-01 11:01:15 +00:00
57be605ed4
Some checks failed
Set up binary cache / cachix (default) (push) Has been cancelled
Set up binary cache / cachix (maximal) (push) Has been cancelled
Set up binary cache / cachix (nix) (push) Has been cancelled
Validate flake & check documentation / Validate Flake Documentation (docs) (push) Has been cancelled
Validate flake & check documentation / Validate Flake Documentation (docs-html) (push) Has been cancelled
Validate flake & check documentation / Validate Flake Documentation (docs-json) (push) Has been cancelled
Validate flake & check documentation / Validate Flake Documentation (docs-manpages) (push) Has been cancelled
Validate flake & check formatting / Validate Flake (push) Has been cancelled
Validate flake & check formatting / Formatting via Alejandra (push) Has been cancelled
Build and deploy documentation / Check latest commit (push) Has been cancelled
Build and deploy documentation / publish (push) Has been cancelled
* lib.neovimConfiguration: deprecated extraModules and configuration * docs: various fixes
58 lines
1.5 KiB
Nix
58 lines
1.5 KiB
Nix
{inputs, ...}: {
|
|
perSystem = {
|
|
config,
|
|
pkgs,
|
|
lib,
|
|
...
|
|
}: let
|
|
docs = import ../docs {inherit pkgs inputs lib;};
|
|
in {
|
|
packages = {
|
|
inherit (docs.manual) htmlOpenTool;
|
|
# Documentation
|
|
docs = docs.manual.html;
|
|
docs-html = docs.manual.html;
|
|
docs-manpages = docs.manPages;
|
|
docs-json = docs.options.json;
|
|
|
|
# Build and open the built manual in your system browser
|
|
docs-html-wrapped = pkgs.writeScriptBin "docs-html-wrapped" ''
|
|
#!${pkgs.stdenv.shell}
|
|
# use xdg-open to open the docs in the browser
|
|
${pkgs.xdg_utils}/bin/xdg-open ${docs.manual.html}
|
|
'';
|
|
|
|
# Exposed neovim configurations
|
|
nix = config.legacyPackages.neovim-nix;
|
|
maximal = config.legacyPackages.neovim-maximal;
|
|
default = config.legacyPackages.neovim-nix;
|
|
|
|
# Published docker images
|
|
docker-nix = let
|
|
inherit (pkgs) bash gitFull buildEnv dockerTools;
|
|
inherit (config.legacyPackages) neovim-nix;
|
|
in
|
|
dockerTools.buildImage {
|
|
name = "nvf";
|
|
tag = "latest";
|
|
|
|
copyToRoot = buildEnv {
|
|
name = "neovim-root";
|
|
pathsToLink = ["/bin"];
|
|
paths = [
|
|
neovim-nix
|
|
gitFull
|
|
bash
|
|
];
|
|
};
|
|
|
|
config = {
|
|
Cmd = ["${neovim-nix}/bin/nvim"];
|
|
WorkingDir = "/home/neovim/demo";
|
|
Volumes = {"/home/neovim/demo" = {};};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|