mirror of
https://github.com/NotAShelf/nvf.git
synced 2024-11-01 11:01:15 +00:00
57be605ed4
Some checks failed
Set up binary cache / cachix (default) (push) Has been cancelled
Set up binary cache / cachix (maximal) (push) Has been cancelled
Set up binary cache / cachix (nix) (push) Has been cancelled
Validate flake & check documentation / Validate Flake Documentation (docs) (push) Has been cancelled
Validate flake & check documentation / Validate Flake Documentation (docs-html) (push) Has been cancelled
Validate flake & check documentation / Validate Flake Documentation (docs-json) (push) Has been cancelled
Validate flake & check documentation / Validate Flake Documentation (docs-manpages) (push) Has been cancelled
Validate flake & check formatting / Validate Flake (push) Has been cancelled
Validate flake & check formatting / Formatting via Alejandra (push) Has been cancelled
Build and deploy documentation / Check latest commit (push) Has been cancelled
Build and deploy documentation / publish (push) Has been cancelled
* lib.neovimConfiguration: deprecated extraModules and configuration * docs: various fixes
64 lines
1.6 KiB
Nix
64 lines
1.6 KiB
Nix
{
|
|
lib,
|
|
stdenvNoCC,
|
|
# build inputs
|
|
nixos-render-docs,
|
|
documentation-highlighter,
|
|
path,
|
|
# nrd configuration
|
|
release,
|
|
optionsJSON,
|
|
}:
|
|
stdenvNoCC.mkDerivation {
|
|
name = "nvf-manual";
|
|
src = builtins.path {
|
|
path = lib.sourceFilesBySuffices ./manual [".md"];
|
|
name = "nvf-manual";
|
|
};
|
|
|
|
nativeBuildInputs = [nixos-render-docs];
|
|
|
|
buildPhase = ''
|
|
dest="$out/share/doc/nvf"
|
|
mkdir -p "$(dirname "$dest")"
|
|
mkdir -p $dest/{highlightjs,media}
|
|
|
|
cp -vt $dest/highlightjs \
|
|
${documentation-highlighter}/highlight.pack.js \
|
|
${documentation-highlighter}/LICENSE \
|
|
${documentation-highlighter}/mono-blue.css \
|
|
${documentation-highlighter}/loader.js
|
|
|
|
substituteInPlace ./options.md \
|
|
--subst-var-by \
|
|
OPTIONS_JSON \
|
|
${optionsJSON}/share/doc/nixos/options.json
|
|
|
|
substituteInPlace ./manual.md \
|
|
--subst-var-by \
|
|
NVF_VERSION \
|
|
${release}
|
|
|
|
# copy stylesheet
|
|
cp ${./static/style.css} "$dest/style.css"
|
|
|
|
# copy release notes
|
|
cp -vr ${./release-notes} release-notes
|
|
|
|
# generate manual from
|
|
nixos-render-docs manual html \
|
|
--manpage-urls ${path + "/doc/manpage-urls.json"} \
|
|
--revision ${lib.trivial.revisionWithDefault release} \
|
|
--stylesheet style.css \
|
|
--script highlightjs/highlight.pack.js \
|
|
--script highlightjs/loader.js \
|
|
--toc-depth 2 \
|
|
--section-toc-depth 1 \
|
|
manual.md \
|
|
"$dest/index.xhtml"
|
|
|
|
mkdir -p $out/nix-support/
|
|
echo "doc manual $dest index.html" >> $out/nix-support/hydra-build-products
|
|
'';
|
|
}
|