mirror of
https://github.com/NotAShelf/nvf.git
synced 2024-11-22 21:30:51 +00:00
24 lines
360 B
Nix
24 lines
360 B
Nix
{
|
|
config,
|
|
lib,
|
|
...
|
|
}:
|
|
with lib;
|
|
with builtins; let
|
|
cfg = config.vim.debugger.nvim-dap;
|
|
in {
|
|
config = mkIf cfg.enable {
|
|
vim.startPlugins =
|
|
[
|
|
"nvim-dap"
|
|
]
|
|
++ optionals cfg.ui.enable [
|
|
"nvim-dap-ui"
|
|
];
|
|
|
|
vim.luaConfigRC.nvim-dap-ui = nvim.dag.entryAnywhere ''
|
|
require("dapui").setup()
|
|
'';
|
|
};
|
|
}
|