mirror of
https://github.com/NotAShelf/microfetch.git
synced 2024-11-01 14:51:14 +00:00
26 lines
301 B
Nix
26 lines
301 B
Nix
{
|
|
mkShell,
|
|
rust-analyzer-unwrapped,
|
|
rustfmt,
|
|
clippy,
|
|
cargo,
|
|
rustc,
|
|
gcc,
|
|
rustPlatform,
|
|
}:
|
|
mkShell {
|
|
strictDeps = true;
|
|
|
|
nativeBuildInputs = [
|
|
cargo
|
|
rustc
|
|
gcc
|
|
|
|
rust-analyzer-unwrapped
|
|
rustfmt
|
|
clippy
|
|
];
|
|
|
|
env.RUST_SRC_PATH = "${rustPlatform.rustLibSrc}";
|
|
}
|