mirror of
https://github.com/NotAShelf/microfetch.git
synced 2024-11-01 06:41:15 +00:00
f1e8ca8773
* add benchmarking * update README to include benchmarking of individual functions * README: formatting * README: add link to Criterion's getting_started * shell.nix: add gnuplot Since Criterion.rs uses gnuplot to generate nice plots, add it to the shell. * Cargo.toml: fixed microfetch binary name * benchmark.rs: fix benchmark function's name * Update README.md --------- Co-authored-by: raf <raf@notashelf.dev>
29 lines
350 B
Nix
29 lines
350 B
Nix
{
|
|
mkShell,
|
|
rust-analyzer-unwrapped,
|
|
rustfmt,
|
|
clippy,
|
|
cargo,
|
|
rustc,
|
|
gcc,
|
|
rustPlatform,
|
|
gnuplot,
|
|
}:
|
|
mkShell {
|
|
strictDeps = true;
|
|
|
|
nativeBuildInputs = [
|
|
cargo
|
|
rustc
|
|
gcc
|
|
|
|
rust-analyzer-unwrapped
|
|
rustfmt
|
|
clippy
|
|
|
|
gnuplot # For Criterion.rs plots
|
|
];
|
|
|
|
env.RUST_SRC_PATH = "${rustPlatform.rustLibSrc}";
|
|
}
|